Welcome to the Treehouse Community
Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.
Looking to learn something new?
Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.
Start your free trialIvo Beckers
728 PointsIsn't this better practice?
I noticed that suitCheck is of the from if (condition) return true else return false
But isn't this like a classical beginner's mistake? Doing "return condition" is much better I think. So I made my suitCheck like this:
fun suitCheck(c1: Card, c2: Card) = ((redSuits.contains(c1.suit) && blackSuits.contains(c2.suit)) || (blackSuits.contains(c1.suit) && redSuits.contains(c2.suit)))